View Single Post
Old 11-29-07, 06:49 AM   #31
BoardDWorld
Registered User
 
Join Date: Apr 2006
Posts: 30
Default Re: GeForce Go 7900 GS black flash screen

Quote:
Originally Posted by Zapek
Ok it works here. So there's definitely a problem when dynamic clocks are enabled. And the reason this gets noticed more in compiz than eg. plain 2D or games is because clocks vary a lot while using compiz. In 2D it seems to be low clocks everytime and when gaming it seems to be high clocks.

Anyway, so in ubuntu you'd have to add this:
Code:
options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved.
Just amazing! There have been so many threads on this and it has gone on for months, 4 months at minimum! Every time a dev will make a single (useless) comment and then disappear... This is unbelievable considering they designed the driver!

I'll trial this for a 24 hours and report back. Thank you all!
BoardDWorld is offline   Reply With Quote