View Single Post
Old 12-11-07, 05:19 AM   #8
LostinSpacetime
Registered User
 
LostinSpacetime's Avatar
 
Join Date: Mar 2007
Posts: 53
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Hi cere88, shaundennie believes that your problems come from the fact that your driver tells the card to lower the clock frequencies when there view to do for it. You can check if this is the case by adding the line

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

in your /etc/modprobe.d/nvidia-kernel-nkc file. BUT BE CAREFUL!!! If you do that, then your card will work at maximum clock frequency all the time, what means it will consume a lot and get very hot. Actually I would do it only for testing. On my system it didn't change (almost) anything. As I already said, I believe the black window issue is related to the amount of ram on your card and fact that the driver isn't using the system ram. By the way, if you can change it in bios (shared) than use the maximum. This might help.

Regarding your performance problems. Have you tried to disable the vertical synchronization for compiz? If you experience an improvement (and I believe you will) and you want back the synchronization, you can do it over the nvidia-settings. It's not exactly the same, but it's doing the job.
LostinSpacetime is offline   Reply With Quote