View Single Post
Old 12-11-07, 05:53 AM   #11
shaundennie
Registered User
 
Join Date: Nov 2006
Posts: 79
Default Re: 8600M GT+Compiz=Slow Animations and Black Window Bug

Quote:
Originally Posted by LostinSpacetime
On my card (5900XT) "0x2222" locks the performance level at maximum. However, it didn't change much. I got the best performance disabling "sync to vblank" at all in compiz (beryl) and enabling the driver's synchronization.
It's been a long time since I've checked this out but, you may be getting better performance at much higher CPU usage. I'm not an OpenGL expert but, long ago, looking at the main render routine for compiz, it would sit and sleep for a vblank if that option was set and then compute the next frame. If it wasn't set it would just shove it to the video card and keep computing and the video card would presumably drop many of those refreshes on the floor as it waited for a vblank. (Though, I admit I only glanced at the code and didn't take the time to fully understand it).

Are you sure that it wasn't simply an issue of having your laptops refresh rate being detected wrong?

Quote:
check General Options->Display Settings and deselect "Detect Refresh Rate" and then manually move the slider to your laptops refresh rate. It used to the be the case that some laptops would be detected as having a refresh rate of 59.9Hz and it would get rounded down to 50Hz. Needless to say, the desktop was not pleasant at that refresh rate.
Keep in mind that once you've set/unset the VBlank setting in nvidia-settings you are essentially looking at a reboot (or maybe just a module reload) before you have "purged" the old settings. In my experience, the default nvidia settings are NOT to be touched when using a composited desktop on a laptop (every slider, no matter how enticing, has made my life hard). Set them to default and then fiddle with the compiz settings until it works nicely.
shaundennie is offline   Reply With Quote