View Single Post
Old 12-15-07, 06:03 AM   #1
technoid
Registered User
 
Join Date: Jul 2004
Location: Denton, Texas
Posts: 505
Default MySQL Connect Problem

I created a small MySQL project on my personal ISP and after getting it going I tried to move it our server at work. I installed MySQL 4.1 and the 3.5 Connect Driver but I can't connect to the database. I keep getting the error below. I output the connect string so you can see how I'm trying to connect.

I installed HeidiSQL a freeware admin utility and can use it just fine. I created a table just like the one in the project on my personal ISP so MySQL seems to be installed and working correctly on the server itself. But I don't know enough about it to troubleshoot the connect problem. I've done a lot of google searches and it seems like my connect string is okay but I'm not sure about what to put in for the server. I put the normal url since that seems right, but maybe not. If anyone has any ideas on this I'd appreciate any help you can offer.

Quote:
Driver={MySQL ODBC 3.51 Driver};SERVER=http://omapsw-w-web.sc.ti.com;PORT=3306;DATABASE=sdpgroup;UID=root ;PWD=xxxx;OPTION=3;
Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

/cellularsystems/tools/test/mysql/inventory/sqlcon.asp, line 16
__________________
Antec-SOLO | ASUS-P5Q-SE | C2D-E8600 | AC-Freezer-7-Pro | Seasonic-S12-550W | 3GB-KVR-PC2-6400 | GTX-560Ti | SB-XtremeGamer | Pioneer-BDR-205 | Samsung-S223B | Dell-U2412M
technoid is offline   Reply With Quote