View Single Post
Old 12-17-07, 02:36 PM   #1
entropathy
Registered User
 
Join Date: Dec 2007
Posts: 1
Default 2 GPUs and 3 Displays

Greetings,

I have an Asus M2NPV-VM MoBo with an onboard Nvidia chip...

00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)

I also have a GeForce 6600 PCI-E card installed

03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 LE] (rev a2)

I've been using the 6600 with 2 monitors for a while, and while poking in the bios saw that the mobo had the option to keep the onboard video enabled as well. So I thought I'd create a new X display and get 3 monitors going.

The nvidia-settings app recognizes everything like it should and the xconfig it generated works like I want , there is just one problem. The third display it very very dim, but it does function like it should, you can just barely make it out. I've tried several different monitors and verified it's what the port is putting out and not my cables or displays. Here is my X config, I was simply using the 2 ports on the 6600 in a twinview config and then just wanted the third screen for displaying status stuff, so it's fine as a seperate X display..any thoughts ?

Quote:
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 1024 0
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AOC FT9x0 Series"
HorizSync 30.0 - 98.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor1"
VendorName "Unknown"
ModelName "AOC Spectrum9K"
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6600 LE"
BusID "PCI:3:0:0"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150"
BusID "PCI:0:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT-0: 1600x1200 +0+0, CRT-1: 1600x1200 +1600+0; CRT-0: 1280x1024 +0+0, CRT-1: 1280x1024 +1280+0; CRT-0: 1024x768 +0+0, CRT-1: 1024x768 +1024+0; CRT-0
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "metamodes" "1024x768 +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Any help on whether this should be a viable configuration or not is much appreciated.
entropathy is offline   Reply With Quote