View Single Post
Old 02-04-08, 06:37 PM   #1
frase
Registered User
 
Join Date: Apr 2007
Posts: 15
Default Cannot get X.Org to start in 75Hz

Running FreeBSD 7.0 RC1, nvidia driver 169.04, X.Org 7.3 (server 1.4.0).
The monitor is a Samsung 940BW and the GPU is an 8800GT.

For some time I have been unable to start X at a refresh rate of 75Hz, although it used to work fine. I can also set the refresh rate manually using nvidia-settings. Anyhow, I'll post my xorg.conf in the hope that someone will be able to tell me what the problem is...

Code:
Section "ServerLayout"
    Identifier      "X.org Configured"
    Screen          "Screen0" 0 0
    InputDevice     "Mouse0" "CorePointer"
    InputDevice     "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
    FontPath        "/usr/local/lib/X11/fonts/OTF"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
    Load            "extmod"
    Load            "record"
    Load            "dbe"
    Load            "glx"
    Load            "xtrap"
    Load            "freetype"
    Load            "type1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Modeline       "1280x1024_75.00"  138.8  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
    Modeline       "1440x900_75.00"  136.8  1440 1536 1688 1936  900 903 909 942 -hsync +vsync
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:4:0:0"
    Option      "NoLogo"                "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes       "1440x900_75.00"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "true"
EndSection
tia

frase
frase is offline   Reply With Quote