View Single Post
Old 07-12-03, 02:19 PM   #10
Hydroxides
Registered User
 
Join Date: Jun 2003
Posts: 7
Default

Well, short of being bothered to look for a more elegant and proper solution I just gave in and wrote an init.d script.

http://www.pi-software.org.uk/nvidia

It's not very well written, nor tested and I won't accept liability for any damage caused. Use it at your own risk. Having said that, I trust my own machine to it and it hasn't given me any grief thus far.

As root, you'll need to copy it to /etc/init.d/ and set the executable flag (chmod +x nvidia). Next, start up Yast2 and select System. Now start the Runlevel Editor. Click Runlevel Properties, scroll down to and select "nvidia" in the list and click Set/Reset in the bottom right. Select "Enable this service". Now click Finish and next time you boot you'll see an additional item in your verbose mode listings - "Force loading NVIDIA gfx module ".

This is perhaps a better means of solving the problem than putting the insmod in rc.local since this script will unload the module when you change run levels, saving you memory. Of course, if you rarely/never change runlevels this is somewhat of a moot point. It's also easier this way for people who aren't comfortable with altering scripts and who want to be able to enable/disable the fix from a nice GUI.
Hydroxides is offline   Reply With Quote