View Single Post
Old 02-21-08, 07:43 AM   #43
Go7300
Registered User
 
Join Date: Jun 2007
Posts: 38
Default Re: GeForce Go 7900 GS black flash screen

It's repeatable here. I left the laptop on overnight, compiz running, gkrellm, firefox, nvidia-settings, openoffice, konsole, speedcrunch, amarok and thunderbird. I left nvidia-settings showing the powermizer page and the focus was on thunderbird. In the morning, I jiggled the mouse to disable the screensaver, then used tab to move the cursor on thunderbird to the mail select panel, then used the down arrow to go to the last mail message, then hit return to open the message. This is where the freeze occurred. It lasted less than a minute. I could tell it was frozen also by watching gkrellm stop responding. Also, since nvidia-settings was opened to the powermizer, I could see that powermizer had never gone below 2.

I also had added this to /etc/modprobe.d/options before this freeze occurred:

options nvidia NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"

But, it does not appear to have registered the PerfLevelSrc, as shown by:

~$ cat /proc/driver/nvidia/registry
EnableVia4x: 0
EnableALiAGP: 0
NvAGP: 3
ReqAGPRate: 15
EnableAGPSBA: 0
EnableAGPFW: 0
Mobile: 1
ResmanDebugLevel: 4294967295
RmLogonRC: 1
ModifyDeviceFiles: 1
DeviceFileUID: 0
DeviceFileGID: 0
DeviceFileMode: 438
RemapLimit: 0
UseCPA: 4294967295
UseVBios: 1
RMEdgeIntrCheck: 1

Notice that the Mobile: 1 setting made it in. I'm using 169.09 .. maybe the PerfLevelSrc=0x2222 means nothing anymore. Anyway, it did not stop the freeze anyway.

Also, since my powermizer never showed less than 2, perhaps it has nothing to do with switching powermizer levels anyway.

Any ideas?

GeForce Go 7300, Ubuntu 7.10, dell e1505 laptop
Go7300 is offline   Reply With Quote