View Single Post
Old 09-08-02, 09:01 PM   #4
Registered User
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default GPL license...

I get this message too.

The Nvidia driver is not GPL ( Gnu Public License ), and some modutils don't like this.

With an XFconfig well configured...
If Nvidia doesn't load into kernel automaticaly, is for this reasons...

1: /etc/modules.conf doesn't have a proper line
alias char-major-195 NVdriver

2: insmod doesn't like Nvidia driver why is NOT GPL

3: We have compiled a new kernel, and insmod don't find the proper driver

In Case 2: we have two options.

Change modutils,


adding a /sbin/insmod -f NVdriver in "/etc/rc.d/rc.local" to force insmod to load the driver.

Perhaps there is more solutions, but

I always install from source.rpm ( I use Redhat, but I change the kernel sometimes )

And I have to recompile Nvidia_kernel and install, for every kernel update
utiel is offline   Reply With Quote