View Single Post
Old 09-08-02, 11:09 PM   #1
LaoTzuTao
Registered User
 
Join Date: Sep 2002
Posts: 23
Send a message via AIM to LaoTzuTao
Angry RPM Source problems

I've been trying forever to get the 2960 drivers to work for my Geforce 3 Ti 200. I'm running SuSE 8.0, I've searched through this forum many times, tried many things, finally I came across one which basically seemed to be the final answer. Installing from the RPM sources instead of the binaries. I'm still rather new to Linux, and have never tried doing that, so I had no idea what I was in for. The first time, I installed the binary for the kernel, then the src.rpm for the GLX but gave me a dependancy error, saying I needed kernel 2.2.0, so I said ok that doesn't sound right. Uninstalled and started over, this time I was planning on install the src for both files. So I installed the src.rpm for the kernel file, but this is what I got in respone...linux:~ # rpm --rebuild NVIDIA_kernel-1.0-2960.src.rpm
Installing NVIDIA_kernel-1.0-2960.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.89609
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd /usr/src/packages/BUILD
+ rm -rf NVIDIA_kernel-1.0-2960
+ /bin/gzip -dc /usr/src/packages/SOURCES/NVIDIA_kernel-1.0-2960.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd NVIDIA_kernel-1.0-2960
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.89609
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd NVIDIA_kernel-1.0-2960
+ set +e
++ rpm -q --queryformat '%{VERSION}' rpm
+ RPMVERSION=3.0.6
++ echo 3.0.6
++ awk -F . '{print $1;}'
+ RPMMAJOR=3
++ echo 3.0.6
++ awk -F . '{print $2;}'
+ RPMMINOR=0
++ echo 3.0.6
++ awk -F . '{print $3;}'
+ RPMPATCH=6
+ '[' 3 -le 3 -a 0 -le 0 -a 6 -lt 4 ']'
+ make NVdriver
/var/tmp/rpm-tmp.89609: make: command not found
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.89609
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd NVIDIA_kernel-1.0-2960
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.18-4GB
+ TARGET_KERNEL=2.4.18-4GB
+ '[' -d /lib/modules/2.4.18-4GB/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.18-4GB/kernel/drivers/video
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-4GB/kernel/drivers/video
+ install -m 0444 NVdriver /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-4GB/kernel/drivers/video
install: cannot stat `NVdriver': No such file or directory
Bad exit status from /var/tmp/rpm-tmp.89609 (%install)
I'm assuming thats bad, So now I'm lost once again, and any help any of you may have would be greatly appreciated. Trying to get these drivers to work has been the reason I've stopped trying to use Linux at all, many times before, so I'm desperate to finally get it working. Thanks! - John
LaoTzuTao is offline   Reply With Quote