View Single Post
Old 03-17-08, 04:37 AM   #22
nvnewser
Registered User
 
Join Date: Mar 2008
Posts: 2
Default Re: Problems with 1.0-9631 on Geforce4 420 Go

Wshutzer, Orlo1010, you guys are ****ing fantastic. This problem was bugging me for months and I had given up on it.

I summarized your solutions for other n00bs like myself

Black bar problem with Nvidia drivers on a Geforce4 420 / 440 Go 16 / 32 Megabyte graphics card? Toshiba Satellite 1415? 14XX? I hear ya. The solution is found in these forums. I've summarized it here.

Here's something that worked for me (on a Toshiba Satellite 1415-S105):
  • download this custom EDID (edid.bin.gz) by clicking the highlighted text.
  • uncompress it to the directory: /etc/X11 (so:it is now "/etc/X11/edid.bin" - not "/etc/X11/edid.bin.gz") - you may need to be root or use "sudo" command to do this
  • open your xorg.conf file (found in the directory: /etc/X11) in a text editor - you may need to be root to do this.
  • add this line to the end of the section marked "Section "Device"" (make a new line and add it right before the "EndSection" line):

    Option "CustomEDID" "DFP-0:/etc/X11/edid.bin"

    that section should now look something like this:

    Section "Device"
    Identifier "nVidia Corporation NV17 [GeForce4 420 Go]"
    Driver "nvidia"
    Busid "PCI:1:0:0"
    Option "AddARGBVisuals" "True"
    Option "AddARGBGLXVisuals" "True"
    Option "NoLogo" "True"
    Option "CustomEDID" "DFP-0:/etc/X11/edid.bin"
    EndSection

    (Don't mind the highlight color)
  • save all your work
  • close open applications
  • restart your xserver by holding down the "CTRL", "ALT" and "Back Space" buttons at the same time

when the login screen appears, you should notice that the black bar has already disappeared. Lucky You!
Log in and you should find that the max resolution of 1024x768 has already been selected and applied for you.

Ubuntu 7.10
nvidia driver version: 1.0-9639
Geforce4 420 Go
Toshiba Satellite 1415-S105

my xorg.conf file is displayed below for your reference:
Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizEdgeScroll"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"nVidia Corporation NV17 [GeForce4 420 Go]"
	Driver		"nvidia"
	Busid		"PCI:1:0:0"
	Option		"AddARGBVisuals"	"True"
	Option		"AddARGBGLXVisuals"	"True"
	Option		"NoLogo"	"True"
#	Option		"RenderAccel" "Off"
#	Option		"NoRenderExtension" "Off"
#	Option		"AllowGLXWithComposite" "Off"
	Option		"CustomEDID" "DFP-0:/etc/X11/edid.bin"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Horizsync	28-51
	Vertrefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NV17 [GeForce4 420 Go]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection
for those of you that can't get into X (your GUI / Desktop), you might want to edit your xorg.conf file from the command prompt with a simple text editor such as vim. You would get X running again by changing
Code:
Driver     "nvidia"
to
Code:
Driver    "nv"
in the "Section "Device"" section, saving, and starting X back up. This would allow you to download the edid.bin file and make the necessary changes with ease. You could also download Puppy OS, burn it to a CD, boot your computer off of that, mount your local HDD, download the edid.bin file, put it in /etc/X11 of the target drive and do the necessary text editing of your xorg.conf with Abiword (for example). In Puppy, you are already root, so permissions wouldn't be a problem.
nvnewser is offline   Reply With Quote