View Single Post
Old 09-10-02, 01:01 AM   #4
icetrain
Guest
 
Posts: n/a
Lightbulb

Heres some info which may be a help to you and many others I have seen with a similar problem. This should also work for other distributions.
The first couple of times I loaded nvidia 2960 drivers on different systems it worked first time, so I had no reason to investigate further, but after reloading mandrake 8.2 on one system, I then ran into the same dead end with the same error messages as you have. After experimenting for a couple of days, and re-installing mandrake 4 times, I found a way to make it work perfectly although it may not be the totally correct way.
What I found:
When Linux is installed it loads the vesa framebuffer driver (xfree 3.3.6) by default, so if you load the nvidia drivers without changing anything it still tries to use xfree 3.3.6 which is controlled by /etc/X11/XF86Config (not XF86Config-4 which is for xfree 4.x).
First, you need to make the system start using xfree 4.x before loading the nvidia drivers or changing other stuff. Also, edit the /etc/inittab file so that xwindows does NOT start automatically each time you restart the system, edit the default runlevel line so that it looks like this:
id:3:initdefault:
Next, change your display settings in mandrake control centre or controlpanel (redhat) or debadmin (debian based) to use an unlisted driver or one of the listed nvidia drivers, but make sure it asks you which xserver to use (3.x or 4.x) during the process otherwise it will keep using 3.x, and DO NOT select to test the configuration, just save it and then select to view the information, it will say at the top which version of xfree it is now set to use (should say xfree 4.2.0).
Then quit that and restart the system, preferably selecting failsafe mode from lilo menu (to minimise any dramas).
Log in as root at the command prompt and load the nvidia driver rpm's as detailed in the nvidia readme, the kernel first then the glx.
Next edit the XF86Config-4 file as detailed in the nvidia readme.
Now try typing startx <enter> to see if the xserver starts successfully. If it does then open a terminal window and type glxinfo <enter> and look for:
direct rendering=yes
If so then all should be okay.
If not, as happened to Kyle and to myself on this occasion, I found that by editing /etc/modules
(not /etc/modules.conf)
and inserting the line:
NVdriver
then forced the nvidia module to load without errors, even though it was listed in the /etc/modules.conf
I hope this wasn't too long winded, but I've tried to summarise what I've found in the past couple of days.
Don't forget to change the /etc/inittab file back to:
id:5:initdefault
so that xwindows will start automatically again, after the problems have hopefully been solved.
p.s. the message "NVdriver 988224 0 (unused)" would be because you did the lsmod from the console, xwindows wasn't running, so NVdriver is not being used, I suspect.
  Reply With Quote