View Single Post
Old 03-31-08, 01:38 PM   #1
chrisccoulson
Registered User
 
Join Date: Mar 2008
Posts: 5
Default OpenGL applications won't run, or they crash or freeze X server

Everytime I open Googleearth, the Googleearth splash appears and then the whole desktop locks up (can't even change VT or do CTRL+ALT+Backspace to restart the Xserver), requiring a hard reboot. If I am lucky enough to have not clicked anywhere on the desktop after it has frozen, I can do CTRL+ALT+F1 and run top. Sometimes, XOrg and compiz.real are redlining my CPU.

If I then change back to my frozen X display from the terminal (CTRL+ALT+F7, or whatever VT the Xserver happens to be running on), the Googleearth splash appears as a white box and the desktop is responsive again (but Googleearth doesn't load). If I close the 'frozen' Googleearth, X crashes completely, taking me back to a login screen again.

If I turn Compiz off, Googleearth runs fine.

Running glxgears also sometimes causes the desktop to freeze. Switching to a terminal and running top show Xorg and compiz.real redlining the CPU. However, sometimes glxgears doesn't cause X to freeze, but I get the following error instead:

Code:
name of display: :0.0
X Error of failed request:  GLXBadDrawable
  Major opcode of failed request:  128 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  24
  Current serial number in output stream:  24
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x7f6d932ea97c]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x15) [0x7f6d932eaa15]
#2 /usr/lib/libX11.so.6 [0x7f6d94880323]
#3 /usr/lib/libX11.so.6(XESetCloseDisplay+0x3f) [0x7f6d94863e0f]
#4 /usr/lib/libGL.so.1 [0x7f6d94f28972]
I've attached the nvidia-bug-report.log. Note, I ran nvidia-bug-report.sh from a terminal after running Googleearth (causing the Xserver to lock up completely).
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (38.5 KB, 127 views)
chrisccoulson is offline   Reply With Quote