View Single Post
Old 04-04-08, 04:47 AM   #1
edhunterbg
Registered User
 
Join Date: Jun 2007
Posts: 28
Unhappy Cant get X running on 7-Stable/i386! (with both 162.12 or xf86-nv-2.1.8)

Hello guys
Here I have a new pc with Intel Core 2 Duo E6700, P35 motherboard, 4GB RAM and Nvidia 8800GT.
I have decided to use i386 version of freebsd, because of nvidia driver

here is short list of details:
New installation of freebsd 7 (snapshot 200803), source updated and world and kernel rebuilded 3.apr.2008
ports also from 4.apr.2008
nvidia-driver from ports version 169.12
linux_base-fc-4_10

I have limited my memory with hw.physmem=2147482624 in /boot/loader.conf
I have used nvidia-xconfig.
Starting X results in black screen and pc locks, I have to reboot it manually!

I gaved up and deinstalled nvidia-driver.
I installed xf86-video-nv-2.1.8 X.Org nv display driver.
But now trying to X -configure results in.
Code:
(EE) NV(0): G80 PROBE_DETECT unimplemented
Why is that i have G92...

So I cant run X neither with open source nv driver, neither with nvidia-driver 169.12
What else I can try? Need help!
10x in advance


p.s.
here is additional info:
Code:
[root@geo ~]# uname -a
FreeBSD geo.pulsar.bg 7.0-STABLE FreeBSD 7.0-STABLE #0: Thu Apr  3 01:03:27 EEST 2008     root@geo.pulsar.bg:/usr/obj/usr/src/sys/GEO  i386
Code:
[root@geo ~]# cat /boot/loader.conf
hw.physmem=2147482624
snd_hda_load="yes"
ichsmb_load="yes"
linux_load="yes"
nvidia_load="yes"
Code:
[root@geo ~]# cat /etc/make.conf
CPUTYPE?=core2
KERNCONF=GEO
WITHOUT_IP6=yes
WITHOUT_IPV6=yes
NO_IPV6=yes
NO_IP6=yes
PERL_VER=5.8.8
PERL_VERSION=5.8.8
edhunterbg is offline   Reply With Quote