View Single Post
Old 04-10-08, 08:03 PM   #5
Registered User
Join Date: Apr 2008
Posts: 5
Default Re: OpenSuse 10.3 installatin failed

Read the README and Installation README where you download the NVidia driver on it's website... or actually I'll just copy paste...

If you have a working X config file for a different driver (such as the “nv” or “vesa” driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the Module section of the file, add the line (if it does not already exist):

Load "glx"

If the X config file does not have a Module section, you can safely skip the last step if the X server installed on your system is an X.Org X server or an XFree86 X release version 4.4.0 or greater. If you are using an older XFree86 X server, add the following to your X config file:

Section "Module"
Load "extmod"
Load "dbe"
Load "type1"
Load "freetype"
Load "glx"
If you follow these instructions, everything should work. I have SuSE too and your Xconfig file should be set to "nv" after installation, once you install the new drivers, you just do this. I also add
Option "NoLogo" "false"
under the driver section, because I like the pretty NVidia splash screen
IkBenDeMan is offline   Reply With Quote