View Single Post
Old 07-23-03, 09:22 AM   #1
Kraft
Registered User
 
Join Date: Jul 2003
Posts: 3
Unhappy GeForce 440 MX + Mandrake 9.1

First of all my GeForce works fine with the distro included driver named "nv".

After processing install the lastest release something strange happens. No way to make server X work


I'm not looking for something accelerated. I need this card for its TV output.
I looked all the different troubleshoots i suppose except if i missed one.
Even tried with the path to the kernel sources
while installing the nvidia driver and the last attempt was with gl headers as i had a complaint
of the Xfree86 unable to find nvidia GLX driver.

THE HARDWARE
------------------------

The motherboard is one winfast 7350KDA on which there is an AMD 2000+
128 MB DDR memory
Brooktree BT878 TV Card
Wacom graphic tablet "Pen Partner"
PS/2 Trackball
Mandrake is configured to be launched using the "noapic" feature because it used to freeze my usb keyboard.


THE SOFTWARE
-------------------------
Mandrake 9.1
Here's the install log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Jul 23 13:37:52 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /root/tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
4363). As part of installing this driver (version: 1.0-4363), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> A precompiled kernel interface for kernel 'Mandrake Linux 9.1 UP Single
Processor i586 Architecture' has been found.
executing: 'cd ./usr/src/nv; /usr/bin/ld -r -o nvidia.o precompiled-nv-linux
.o nv-kernel.o'...
-> Kernel module linked successfully.
-> Installing classic TLS OpenGL libraries.
-> Parsing log file:
-> done.
-> Validating previous installation:
-> done.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-4363):
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
Linux-x86 (1.0-4363) is complete.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-4363):
executing: './usr/src/nv/makedevices.sh'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-4363) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.


Now let's see XF86Config-4

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "stylus"
Option "Mode" "absolute"
Option "Tilt" "on"
Option "Threshold" "5"
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "eraser"
Option "Mode" "absolute"
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/ttyS1"
Option "Type" "cursor"
Option "Mode" "relative"
Option "Speed" "3.0"
Option "Threshold" "10"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
Identifier "monitor1"
HorizSync 30-85
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

EndSection

Section "Device"
Identifier "device1"
BoardName "GeForce 440MX"
Driver "nvidia"
# Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "stylus" "AlwaysCore"
InputDevice "eraser" "AlwaysCore"
InputDevice "cursor" "AlwaysCore"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

So this definition script works ok with touching nothing else but the driver definition.
When i set "nv" it's ok but when i have the idea
to change it for something like "nvidia"

the final result is in the attached file.
Thanks if someone can help me with a real solution.
Attached Files
File Type: log xfree86.0.log (32.0 KB, 176 views)
Kraft is offline   Reply With Quote