View Single Post
Old 04-19-08, 03:41 AM   #115
elclanrs
Registered User
 
Join Date: Apr 2008
Posts: 4
Default Re: 8400M GS : Low performences

Hi!

I'm new into the forum.

I've been following this thread long ago cuz of the related performance problems with my 8800gts card.

After trying everything i could found on many forums nothing worked for me, still the ugly minimize/maximize and scroll problems.

This is the SOLUTION I found that worked for me:

(The instructions below are tested on Ubuntu Hardy "beta", my current OS)

1. Install a fresh and clean Ubuntu and update to the latest.
2. Download and install nvidia driver from official website (169.12)here
3. Disable other nvidia modules that could cause problems

open:
Quote:
sudo nano /etc/default/linux-restricted-modules-common
add:
Quote:
DISABLED_MODULES="nv nvidia_new"
4.Declare nvidia as driver in xorg.conf
open:
Quote:
sudo gedit /etc/X11/xorg.conf
add to the "Device" section:
Quote:
Driver "nvidia"
5. Restart X
6. Enable desktop effects on "Appearance" settings (you can install ccsm to modify some options)


By maintaining a simple xorg.conf and letting ubuntu "desktop effects" take control over compiz instead of "fusion-icon" worked like a charm for me.


Notes:

When I downloaded and activated fusion-icon is when the choppy animations and other stuff started.

When I tried to use nvidia-xconfig to write xorg.conf file I got problems too.

Scroll and tab problems in firefox still persists.


I don't know why this solution works if it's a driver problem (Powermizer or whatever)...
elclanrs is offline   Reply With Quote