View Single Post
Old 05-05-08, 08:50 PM   #55
pferraro
Registered User
 
Join Date: Aug 2007
Posts: 30
Default Re: GeForce Go 7900 GS black flash screen

Quote:
Originally Posted by Spongebob88
I have had this problem since I first tried Linux and I am grateful for the solutions posted in this thread. I locked the gpu in full performance mode and then underclocked it to prevent excess heat and battery drain. After doing this I haven't had any of those damn flickers on my machine.

My question is that it doesn't seem to save my underclocked settings when I reboot, and I have to manually change it every day. Is there any way to save these settings or to create a script that will do it for me(The main fix works perfectly and I never need to change it, just the underclocking part)?
Add the following command to your session startup:
nvidia-settings -a GPUOverclockingState=1 -a GPU2DClockFreqs=200,300 -a GPU3DClockFreqs=500,600

Adjust the 2D and 3D clock frequencies to your desired values.
pferraro is offline   Reply With Quote