View Single Post
Old 05-27-08, 04:16 PM   #1
Fritz_Katz
Fritz Katz
 
Join Date: May 2008
Posts: 1
Default mode 1600x1200 fails after nvidia-xconfig

I'm running FreeBSD 7.0-RELEASE with:
Monitor "Envision22"
Device "GeForce 8400 GS"

The system was working fine with 1600x1200 resolution using basic frame buffer -- but of course GLX programs wouldn't work.

Did this:

# nvidia-xconfig --mode=1600x1200

And rebooted.

Now all the GLX graphics work :-) --- but the screen resolution on my 22" monitor is only 1280x1024

/var/log/Xorg.0.log:
Code:
(II) NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G86) at PCI:2:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.41.00.90
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:2:0:0:
(--) NVIDIA(0):     Bit 3 LE22A3 (CRT-1)
(--) NVIDIA(0): Bit 3 LE22A3 (CRT-1): 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-1
(WW) NVIDIA(0): No valid modes for "1600x1200"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x1024"
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0):     "800x600"
(II) NVIDIA(0):     "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (69, 89); computed from "UseEdidDpi" X config
Anyway to get the higher resolution enabled? I'd like to be able to have my cake and eat it too.
Attached Files
File Type: log Xorg.0.log (25.2 KB, 191 views)
Fritz_Katz is offline   Reply With Quote