View Single Post
Old 06-01-08, 02:54 PM   #1
rcgill
Registered User
 
Join Date: Jun 2008
Posts: 6
Default can't get 2560x1600 (freebsd 7.0, nv, 8500gt, hp lp3065)

I am unable to get X to display 2560x1600. The best I can get is 1280x800. I've constructed a xorg.conf file with the proper modelines (I think), but this doesn't help.

Here's the configuration:

Mainboard: Gigabyte GA-M51GM-S2G
Processor: AMD Athlon 64 X2 3800+ @ 2000 MHz
RAM: 4096 MB
Video Card: MSI NX8500GT-TD512EH
(http://www.msicomputer.com/product/p...12EH&class=vga)
Monitor: HP LP3065
(http://h10010.www1.hp.com/wwpc/us/en...7-3297215.html)
OS: FreeBSD 7.0 amd64 (NOT i386)

Note that I am using the nv driver because the NVIDIA Proprietary Driver doesn't support amd64.

The OS had been freshly installed from the ISO images. I updated the nv driver from ports (xf86-video-nv). Both the driver distributed with the iso install and the updated driver exhibit the same behavior.

This card and monitor clearly should work OK since I have the exact same configuration (MB + CPU + RAM + video card + monitor) on another box running win xp perfectly.

I've appended the relevant files below (xorg.conf, the xorg log (attached), and output from xrandr -q after x is up).

Thanks so much for any help.

Best,
Rawld



Here is the xorg.conf file (note that I tried a couple of modelines in the monitor section).

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/local/share/X11/rgb"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "GLcore"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "HP"
ModelName "LP3065"
DisplaySize 641 400
HorizSync 100.0
VertRefresh 60.0
#ModeLine "2560x1600" 268.0 2560 2608 2640 2720 1600 1603 1609 1646
Modeline "2560x1600" 268.00 2560 2608 2640 2720 1600 1603 1609 1646 +hsync -vsync EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
#Option "FPScale" # [<bool>]
#Option "FPTweak" # <i>
#Option "DualHead" # [<bool>]
Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "GeForce 8500 GT"
BusID "PCI:2:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
Subsection "Display"
Viewport 0 0
Modes "2560x1600"
Depth 24
EndSubSection
EndSection
Attached Files
File Type: log Xorg.0.log (33.5 KB, 179 views)
rcgill is offline   Reply With Quote