View Single Post
Old 06-18-08, 09:41 AM   #6
czecz
Registered User
 
Join Date: Jun 2008
Posts: 3
Unhappy Re: Error module ScreenPrivateIndex

hello!

i have
Code:
# cat /etc/fedora-release 
Fedora release 9 (Sulphur)
# lspci  | grep -i VGA
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
it have 2 VGA outputs: old CRT one and digital one

old CRT works with "nv" driver and i have blurry screen, dvi output doesnt work with "nv" driver.

i used
# sh NVIDIA-Linux-x86-96.43.05-pkg1.run --apply-patch NVIDIA_kernel-96.43.05-2290218.diff.txt
...
Self-extractible archive "NVIDIA-Linux-x86-96.43.05-pkg1-custom.run" successfully created.

as described on http://www.nvnews.net/vbulletin/showthread.php?t=110088
which made me NVIDIA-Linux-x86-96.43.05-pkg1-custom.run

running it produced nvidia kernel module and no errors was found in /var/log/nvidia-installer.log
Code:
# tail -3 /var/log/nvidia-installer.log
-> Your X configuration file has been successfully updated.  Installation of
   the NVIDIA Accelerated Graphics Driver for Linux-x86 (version: 96.43.05) is
   now complete.
now trying to run with startx, leads me to the following error:

Code:
X.Org X Server 1.4.99.902 (1.5.0 RC 2)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-53.1.19.el5 i686 
Current Operating System: Linux mator 2.6.25.6-55.fc9.i686 #1 SMP Tue Jun 10 16:27:49 EDT 2008 i686
...
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
can someone fix driver or make "nv" driver work over DVI connector? Thanks


PS: DVI output works fine with NOUVEAU driver, but firefox (Xorg?) rendering seems to be very very slow....
czecz is offline   Reply With Quote