View Single Post
Old 06-30-08, 09:28 PM   #6
Runningman
Registered User
 
Runningman's Avatar
 
Join Date: Feb 2008
Posts: 925
Default Re: How to make Windows shares go faster

Quote:
Originally Posted by Bman212121 View Post
Just messed with that. I turned of the QOS packet scheduler on Vista 64, and on both boxes I turned off priority and vlan. No difference. The I turned off flow control on one, no difference, flow control on both, no difference.

The one thing to note though is when you reuse the same file, it is cached in ram, so the first couple of seconds I can get as high as 60% usage when pulling files from the xp 32 box to the vista 64 box. It seems more like a windows sharing program issue with reading files off of the drive. As I've said before, if I did two transfers from two different sources at the same time, it will use more of the gigabit connection. I get about 50% more throughput right now doing that from adding USB enclosures on each end on top of the normal drives. It's still only using 30 - 35% of the connection though, but it's up from about 20% right now.


EDIT: Did a little more browsing and I found a similar thread at [H]

http://www.hardforum.com/showthread.php?t=1170983

Sounds like it's mainly an XP issue. The thing is there are a few people that say you need to do some "tweaks" but sure haven't been able to come across any of these magical tweaks. I'll have to try a server03 install with my vista install and see if it will max out the hdd.

EDIT2:

Just tried Filezilla Server like they suggested. It's installed on the windows XP box and I put the UT3 folder as the FTP folder. Now I'm pulling 45% when downloading, and about 27% uploading using the built in explorer in Vista64. Looks better but I'm going to try the filezilla client and see if it will go even faster.

Using the FZ client it now does about 65% in both directions. I know I've tested this in the past and didn't see results like this, so I'm guessing they have made some peformance tweaks since a couple years ago.

Either way I think the bottom line is that if you want to fully use your gigabit network make sure both pcs are running something newer than xp.
sorry i wasn't more specific with my answer but i didnt really have time for a complete write-up.
first off im assuming you tried newer or older NIC drivers, second try to disable the QOS feature with gpedit

try these instructions
Quote:
Increasing connection speed
Some of us may find that after installing Windows XP, the Internet connection gets slower. A possible reason for this is the QoS (Quality of Service) installed. This service reserves 20 per cent of the bandwidth for itself, even with QoS disabled. In order to remove this reserved quota, you will have to make sure you are logged on as Administrator. Go to Start > Run and type gpedit.msc. Expand the ‘local computer policy’ branch, the ‘administrative templates’ branch, and the ‘network’ branch. Highlight the ‘QoS Packet Scheduler’ in the left window and in the right window double-click the ‘limit reservable bandwidth’ setting. Then, on the Setting tab, check the ‘enabled’ item and change the ‘Bandwidth limit %’ to read 0. After doing this, you should immediately notice a boost in your Internet connection speed.

You also need to verify that QOS packet scheduler is enabled in your network connection properties done by going to control panel > network connections > right click on your connection > properties > check mark for QOS.
edit i found somthing that might be a good read.
http://kbalertz.com/814112/Files-Net...r-Message.aspx
Runningman is offline   Reply With Quote