View Single Post
Old 07-06-08, 09:20 PM   #1
xsolarwindx
Registered User
 
Join Date: May 2008
Posts: 135
Default nVidia 8000/9000 Series Performance Issues

This topic discusses the poor 2D performance of 8000 and 9000 series nVidia cards on Linux due to low quality drivers. If you are experiencing any performance issue whatsoever and you have an 8000/9000 series nVidia card, please post on this thread. Also, please post if you own one of these cards and you DO have good 2D performance. You can even post just to say:
Quote:
Originally Posted by solidsnak View Post
Dear Nvidia,

Fix your drivers.

Sincerely,
Another dissatisfied customer.
(^ One of my favourite quotes in this thread, hehe.)
In either case, please be sure to state the exact model of the card (including the vendor: bfg, evga, xfx, etc...), your driver version and any other relevant information.

Update: I've submitted the article to digg. Please digg to raise awareness of this issue!

DIGG IT!


Maybe with enough posts, we can actually get nVidia to listen! So spread this thread, tell your friends about it, link it on your blog or other forums and I hope NVIDIA fixes this problem. Hopefully before the much anticipated release of KDE 4.1 at the end of July.

Here are some threads discussing such issues:
http://www.nvnews.net/vbulletin/showthread.php?t=101161
http://www.nvnews.net/vbulletin/showthread.php?t=114858
http://www.nvnews.net/vbulletin/showthread.php?t=115840
http://www.nvnews.net/vbulletin/showthread.php?t=115724
http://www.nvnews.net/vbulletin/showthread.php?t=109990

Some blog articles/other forum posts about the same issues:
http://www.larsen-b.com/Article/290.html
http://www.phoronix.com/scan.php?pag...item&px=NjU5Mw
http://www.phoronix.com/forums/showthread.php?t=11044
http://liquidat.wordpress.com/2008/0...reedy-problem/ - Thanks for the link, sarev!
http://techbase.kde.org/User:Lemma/GPU-Performance - kde.org

Obviously, this is a very well known, frustrating and irritating issue. There are many more links, but these are the ones I had bookmarked.

The problem:
  • Horrible 2D performance in Linux with the nVidia drivers. 169, 173 and 177 drivers are all faulty.
  • Firefox scrolling/switching tabs performance is horrible.
  • Resizing windows/moving windows/scrolling in windows is slow/laggy.
  • KDE4 is almost unusably slow.
  • Xrender performance is horrible.
  • Compiz Fusion very choppy, laggy minimize/maximize.
  • KDE4/QT4 apps especially are very laggy and unresponsive. Example: button press, dragging/resizing windows, combo boxes, menus are all slow.

So far, no solutions for this problem exist. This is a major problem since 2D performance is far more important to most people than 3D performance. The 3D performance on Linux so far has been great, but I can't say that for the 2D performance.

The solution?
  • In one or more posts from the above mentioned threads, an nVidia representative assured us that a fix was on its way. However, several painful months passed by and we still don't have a solution. Many of us are still forced to live with poor quality drivers after shelling out several hundreds of dollars for a card. When will the drivers be out, nVidia???
  • USE THE LATEST 177 BETA DRIVERS. The latest 177 beta drivers have improved greatly. Here's a link to the download: http://www.nvidia.com/object/linux_d...32_177.13.html
  • Update (2008-07-08): Numerous users have reported (I have tested and confirmed) that using the 177 beta drivers straight from the nVidia website and then issuing the following command will greatly improve 2D performance. Although it is nowhere near where it should be, resizing windows and firefox scrolling is a lot more bearable now. I haven't tested compiz-fusion yet, but I will be doing that shortly.
    Quote:
    nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
    The above command should be put in a startup script somewhere so it executes everytime you login to your desktop environment. Note that you do not need to restart your X server for the changes to take effect. Restarting your X server only causes it to forget the changes. That is why you must put the command in a startup script.
  • Update (2008-07-08): Compiz Fusion seems to be running ok, but the resizing windows is still unbearable. Some plugins still lag. I need to test KDE4 now. Will post more in-depth soon.
  • Update (2008-07-09): Adding Option "PixmapCacheSize" "200000" to the Device section in your xorg.conf should improve 2D quite a bit. Still have to try out KDE4.
  • Update (2008-07-18): If you've been following with the thread, I've found a way to make a snappy desktop by accident. Here's a guide. Hope it helps - but please post back and share your experience:

Code:
1. Uninstall any nvidia official drivers. If you're using an Ubuntu based distribution, follow the steps below. If you're using a more "do it yourself" distro like Arch Linux, then you should know how to remove the drivers.

1.1 Uninstall nvidia official drivers on Ubuntu based distros:    
    * Edit /etc/modules and add "nvidia" to the list.
    * Edit /etc/default/linux-restricted-modules-common and add "nv" (without quotes) to the restricted list. It should look like this: DISABLED_MODULES="nv"

    * Run the following commands to clean up your distro of any nvidia residue:
    $ sudo envy --uninstall-all 
    $ sudo dpkg -P envy 
    $ sudo apt-get remove --purge nvidia*
    $ sudo rm /lib/restricted-modules/.nvidia*
    $ sudo nvidia-installer --uninstall

    * Backup your /etc/X11/xorg.conf.

2. Remove xorg.conf and install binary drivers.
    * Run the following to remove your old xorg.conf so the nvidia setup can make you a new one.
    $ sudo rm /etc/X11/xorg.conf
    * Switch to a terminal (CTRL + ALT + F5 or something) and stop GDM or whatever you use (this will also stop X):
    $ sudo /etc/init.d/gdm stop
    * The next step will instal the drivers. Just answer yes to all questions and you'll be fine.
    $ sudo sh <the latest nvidia installer that you downloaded from the nvidia website>
    
3. Improve performance:
    * Edit /etc/X11/xorg.conf and add the following line to the "Device" section:
    Option "PixmapCacheSize" "300000"
    Option "OnDemandVBlankInterrupts" "True" (Thanks to Alejandro Nova for kindly pointing this out)
    * For reference, my xorg.conf looks like this: http://www.paste.metafy.org/view.php?file=hEdesEzUpyqU.txt&language=
    * Now put the following in a script: http://www.paste.metafy.org/view.php?file=amUgAnadYhEr.txt&language=
    * Run it everytime your windw manage starts. (You can put it in your Gnome startup through the session manager - just make sure to chmod +x the script.)
    * Now this is where the performance really improved for me: I was fooling around and used the "Carbon" theme (Candido engine) that came with my Linux Mint installation. So download the Candido gtk2 engine, download the following themes and put them in your ~/.themes directory.
    * Download slightly modified Carbon theme and the Elyssa theme: http://www.mediafire.com/?1kt32wexdgm
    * In your appearance settings, select "Carbon" to be the theme for controls and "Elyssa" to be the Metacity theme.

4. Test:
    * Fool around, resize windows (make sure reduced_resources is OFF in gconf-editor, so that dragging/resizing is opaque and not in wireframe mode). Test firefox scrolling, resizing, whatever. Post on this thread and share your experience.
    * Note that with compiz-fusion on, resizing is still poor, but when compiz-fusion is off, everything seems to be snappy.
  • Update (2008-07-21): I just removed Linux Mint and installed and set up Arch Linux. A lot of the Firefox lag I noticed is mostly gone but there's still a lot of lag when switching tabs sometimes. I'm running XFCE as my main WM and it's blazing fast. I'm going to try KDE4 on Arch Linux and see how it goes.
  • Update (2008-07-26): Alejandro Nova has kindly pointed out (http://www.nvnews.net/vbulletin/show...51#post1723951) a way to enable "desktop effects" with relatively good performance. Here's a copy of his guide:

Quote:
1. Right click on your title bar, and select, in KDE 4, "Configure window behavior".
2. In "Desktop Effects", select "Advanced options".
3. Select the following:
Composition type: OpenGL.
OpenGL Mode: Shared memory (ENABLE THIS AFTER YOU ENABLE DIRECT RENDERING, IF YOU DO OTHERWISE YOU WILL EXPERIENCE SCREEN CORRUPTION)
Direct rendering: Enabled
VSync: Enabled

These settings, with Option "OnDemandVBlankInterrupts" "True" in my xorg.conf Device section, are yielding less CPU usage and better performance here (KDE 4.0.99)

Note (by solarwind): even if you do not want to use "desktop effects", I found that enabling "OnDemandVBlankInterrupts" "True" in the xorg.conf Device section improve things quite a bit.
Notes:
Just a few days ago, my friend needed help deciding between an nVidia and an ATI card. If this was last year or two years ago, I would have recommended an nVidia. However, times have changed. I told him to go grab an ATI and don't think again. I helped him install it and the performance was amazing all round. 2D/3D Linux/Windows, everything. If I had known of this problem earlier, I would have got myself an ATI.

Discuss.

Please post more links to similar performance issue threads so I may add them to the list. Also post any blog articles about this as well. There were a few that I remember reading, but forgot to bookmark.

Last edited by xsolarwindx; 07-29-08 at 07:54 PM.
xsolarwindx is offline   Reply With Quote