View Single Post
Old 07-25-08, 07:40 PM   #18
FearMeAll's Avatar
Join Date: Jul 2004
Location: Georgia, USA
Posts: 827
Default Re: DirectX 10, BioShock and Anti-aliasing

Originally Posted by Stevedroid View Post
You either enabled SSAA at the global level instead of the profile (I forgot to ask that) or you don't have the correct NvApps.xml, there's no AA enabled there.

I'm guessing you got the one from C:\Windows\System32\. It seems nVidia no longer keeps NvApps.xml there (you might have one from an old driver set). It's now under C:\ProgramData\NVIDIA\. ProgramData is typically hidden so you have to manually type it in in Explorer.

That said, don't bother. I ended up downloading nHancer. 2x2 supersampling corresponds the following settings:

<PROPERTY Label="aa_selector" Value="0x10000000" Default="0x00000000" />
<PROPERTY Label="aa_default" Value="0x00000005" Default="0x00000000" />

At least that's the entires that nHancer added in Bioshock's section. However, SSAA didn't work when enabled at the profile level, it did work when enabled at the global level. I have the Steam version of the game, so it's possible the drivers aren't recognizing the .exe - that said the profiles work for other games I have on Steam.
I just used the NVapps.xml off of windows search. I know in nhancer the only thing I did was enable the Bioshock profile to work with 4x4 SSAA. It worked for me and now you have me scared to ever update my drivers.
Consoles: Xbox Elite with HDDVD drive and PS3.
Panasonic AX200U Widescreen Projector (1280x720), 160" HighPower Screen, AND A BIG COUCH.
[FONT="Courier New"] HTPC: Intel Wolfdale 3ghz, 4 gigs DDR2 800 ram, 500gig HDD, Craptastic 7600GS, Windows 7 32bit, XBMC installed [/FONT] :D
[B]My Video Encoding/Office rig:[/B] [I] Intel QX9650 @ 3ghz, 1333mhz FSB, 4gigs Patriot Extreme DDR3 @ 1333mhz, XFX 790i 3-way Sli mobo, Xf-Fi Extreme Gamer, 400watt Fanless Power Supply, 9500GT 64-bit bus(ouch!), 8.750TB HDD, Windows 7 64-bit Ultimate. [B][FONT="Arial Narrow"]Everything at stock and completely boring..[/FONT][/B][/I] :type:
FearMeAll is offline   Reply With Quote