View Single Post
Old 08-09-03, 08:12 PM   #1
jager
Registered User
 
Join Date: Aug 2003
Posts: 11
Angry AGP Support Disabled

I get really slow performance in my 3d games. No lockups or crashes...just very slow performance.
Lots of people seem to be having similar problems but I don't seem to be able to relate their information and solutions to my problem. I have tried option "NvAGP" "1"...2 and 3 none of them seem to do anything. AGPGART doesn't appear to be loading nor does NvAGP. I really feel like the fact that agp is disabled is my problem but I can't figure out how to get it enabled.
Here are my specs:

Nivida Driver Version 1.0-4496
Model: GeForce4 MX 440
IRQ: 11
Video BIOS: 04.17.00.30.11
Card Type: AGP
PIII 800

/proc/driver/nvidia/agp/status
Status: Disabled

My XFree86 file:
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Hitachi CM2198M"
HorizSync 30.0 - 94.0
VertRefresh 50.0 - 150.0
Option "dpms"
EndSection

Section "Device"

# BusID "PCI:1:0"
Identifier "NV AGP"
Driver "nvidia"
VendorName "nvidia"
BoardName "NVIDIA GeForce 4 MX (generic)"
option "NvAGP" "1"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "NV AGP"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "DRI"
# Group 0
# Mode 0666
#EndSection
#


Any help is truely appreciated.
jager is offline   Reply With Quote