View Single Post
Old 08-11-03, 03:22 AM   #8
Registered User
Join Date: Aug 2003
Location: Vancouver, BC, Canada
Posts: 4
Default Check that the AGPGART driver isn't loaded

NvAGP="1" is requesting that you only use the nvidia driver's internal agp driver.

A) Have you checked the nvidia driver's README to ensure your motherboard's AGP hardware is directly supported by the nvidia driver? If it isn't, then you will want to use the kernel's agpgart driver and update your XF86Config's NvAGP setting to have it request use of the agpgart (not nvidia's internal) agp driver.

B) Have you directly loaded the nvidia module, via modprobe? If not, try modprobe nvidia and then look at the /proc's agp status again.

C) Despite being loaded, the nvidia module will fail to initialize agp if you either #1) compile the kernel's agpgart driver into the kernel (kernel option "y") or load agpgart as a module (kernel option "m").

Maybe one of these three issues is the problem?

Last edited by Glorandar; 08-11-03 at 03:27 AM.
Glorandar is offline   Reply With Quote