View Single Post
Old 08-21-08, 02:31 PM   #7
Gentoo Linux addict
Join Date: Nov 2007
Location: Vienna, Austria; Germany; hello world :)
Posts: 208
Default Re: How to disable powermizer?

use the google, luke !


I've found this thread in forums:

From the thread:
"Did you already try to set the mysterious PerfLevelSrc option?
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

It's never been explained by nvidia what it does, but it's evident that it helps some people (including me) to avoid flickering and XID errors.
It seems to disable adjustment of clock frequencies and helped in my case to avoid the flickering on a 7900 Go GS (Dell 9400). Of course the GPU gets hotter without clocking down so use it with care."

From another user:
"options nvidia NVreg_DeviceFileMode=432 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=27 NVreg_ModifyDeviceFiles=1 NVreg_SoftEDIDs=0 NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"

And specifically for Ubuntu users:
"Anyway, so in ubuntu you'd have to add this:

options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"

in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved."

I'm currently trying this out. Maybe someone is interested, so this is why I share these comments here.
Adding the "options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"" line lets it know its a mobile card - if you look at the line closely, you can see its setting the NVreg_Mobile nVidia option to '1' or 'True'. This is what fixed it for me - without this, your system doesn't know it is working with a mobile card - the only cards with Powermizer, therefor the only cards that the PerfLevelSrc options apply to...
(did this work for you ?)
3.19.2-plus+ w. zram, ZFS, Btrfs; checksums>others

Gentoo all the way
kernelOfTruth is offline   Reply With Quote