View Single Post
Old 08-16-03, 08:36 AM   #9
Max3D
Quadro2 Pro
 
Join Date: Jul 2002
Posts: 28
Default

I don't claim this will help "you", but might be worth a try just cause I been down this road and was no fun, was determined to get APIC or ACPI working but in the end it was out of my hands as I not a linux kernel programmer but a tweaker instead.

Heres all I did to stop lockups:
Enable APIC and ACPI in BIOS, then go into "make menuconfig" and leave ALL power management completely OUT of the kernel (APIC, APIC-IO, ACPI & regular Power managment) all unchecked, then enable Athlon CPU type, Enable MCE(Machine Check Exception), enable MTRR, right now you might be wondering why did I leave them enabled in BIOS?, simply cause I dual boot with XP and it's blazingly fast with it (very responsive), anyhow... build your new kernel-2.4.22-pre3-ac1 (or newer) without all this PM stuff and give it a try, might work different than the boot time disabling switch options, does for me. good luck, just my 02 cents.

If that APIC/ACPI patch works let us know, I'd be willing to give it a test drive.

cat /proc/pci shows (Rev 162) here.

btw: If you need to see my kernel config let me know and I'll try to find a way to link post it here.

Last edited by Max3D; 08-16-03 at 11:46 AM.
Max3D is offline   Reply With Quote