View Single Post
Old 09-07-08, 08:43 AM   #2
glaurung
Registered User
 
Join Date: Sep 2008
Location: Greece
Posts: 2
Default Re: NVIDIA Driver for linux >=173.xx.xx fails, whereas 169 used to work.

I have now upgraded X Server to 1.5.0 in gentoo. Same problem, approximately the same logfile, only it gets stuck at line 29.
Code:
X.Org X Server 1.5.0
Release Date: 
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.26-gentoo-r1 x86_64 
Current Operating System: Linux gandalf 2.6.26-gentoo-r1 #1 SMP Thu Aug 28 14:24:23 EEST 2008 x86_64
Build Date: 07 September 2008  03:30:31AM
...
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 4.1
        X.Org XInput driver : 2.1
        X.Org Server Extension : 1.1
        X.Org Font Renderer : 0.6
...
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "UseEdidDpi" "false"
(**) NVIDIA(0): Option "DPI" "90x90"
(**) NVIDIA(0): Option "AddARGBGLXVisuals"
(**) NVIDIA(0): Option "DynamicTwinView" "false"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 8500 GT (G86) at PCI:3:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.65.00.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8500 GT at PCI:3:0:0:
(--) NVIDIA(0):     LG L227W (DFP-0)
(--) NVIDIA(0): LG L227W (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): LG L227W (DFP-0): Internal Dual Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "1680x1050_50.00"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024_100.00"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1024x768"
(II) NVIDIA(0):     "800x600"
(II) NVIDIA(0):     "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(**) NVIDIA(0): DPI set to (90, 90); computed from "DPI" X config option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[b]
        [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [4] -1  0       0xffffffff - 0xffffffff (0x1) MX[b]
        [5] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [6] -1  0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [7] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [8] -1  0       0xffffffff - 0xffffffff (0x1) MX[b]
        [9] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [10] -1 0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [11] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [12] -1 0       0xffffffff - 0xffffffff (0x1) MX[b]
        [13] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [14] -1 0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [15] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [16] -1 0       0xffffffff - 0xffffffff (0x1) MX[b]
        [17] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [18] -1 0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [19] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [20] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [21] -1 0       0x00000000 - 0x00000000 (0x1) IX[b]
        [22] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [23] -1 0       0x00000000 - 0x00000000 (0x1) IX[b]
        [24] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [25] -1 0       0x00000000 - 0x00000000 (0x1) IX[b]
        [26] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [27] -1 0       0x00000000 - 0x00000000 (0x1) IX[b]
        [28] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [29] -1 0       0x00000000 - 0x00000000 (0x1) IX[b]

           CRASH!!!!
my xorg.conf works fine with the nv driver (I only make the changes to the modules Section regarding dri, GLCore and glx)
glaurung is offline   Reply With Quote