View Single Post
Old 08-18-03, 02:38 PM   #1
desperate5200
Registered User
 
Join Date: Aug 2003
Posts: 4
Question FX5200 'no screens found' Fatal server error

Hi,
I don't consider myself a linux newbie, I even got a Intel WLAN pcmcia card to run on a Thinkpad under linux once and that took some patience, but I'm far from being a linux crack.

I just CANT get the latest NVIDIA driver (the NVIDIA-Linux-x86-1.0-4496-pkg2.run) to work. I've tried virtually all possible combinations from the most likely to the most unlikely, none worked.

My machine:
Athlon XP 2600+
ASROCK K7S8X Motherboard
512 MB Ram
GForce FX5200 (128MB) (from XFX, BIOS Version 4.34.20.18.00)
Suse 8.2 with all possible updates as of Aug-18-2003 running the updated k_athlon kernel

I've tried about 5 times to do it the conventional way, like it says on the Suse-page (i.e. copying the neccessary files and make cloneconfig dep, with all the latest sources installed, then compiling my own nvidia-kernel because no precompiled one was found with IGNORE_CC_MISMATCH=yes) with all sorts of different resolutions. The driver compiles and installs fine. When I go to sax2 and enable the 3D accelleration it automatically switches to 'nvidia' instead if 'nv', as it should, but when I test the x-server I only get a black screen everytime, which I cant even ctrl-alt-backspace out of.

When that failed I virtually raped the driver in all possible ways, in the end doing everything manually, such as editing the XFree86.conf, forcing to use old precompiled kernels and so on.

I know I was doing it right, because at work I did the same procedure (the conventional one) with my RIVA TNT2 1 GHz Athlon and everything worked beautifully. I use the same Suse version and the exakt same software setup.

But on my machine at home NOTHING worked!

I've attached the XFree error log. The interesting stuff is in the end. I don't really know what to do with the 'no screens found' error. I've tried various different resolutions, all produce the same result.

I would really appreciate help!
Thanks.
Attached Files
File Type: log xfree86.log (16.6 KB, 142 views)
desperate5200 is offline   Reply With Quote