View Single Post
Old 09-10-08, 09:15 PM   #7
bigadel
Registered User
 
Join Date: Sep 2008
Posts: 1
Default Re: How to disable Full GPU Scaling on X startup

Hi all !

I have a dual screen configuration with a normal flat panel plugged on the first DVI out of my GeForce 8800 GTS and an DVI to SDI adaptator plugged on the second output.
The converter need a 720x576 50Hz output resolution. I configured my xorg to do so.
But when the Full GPU Scalling is enabled, then I didn't get any image trough the interface.
So, I need to start nvidia-settings and then unchecked the corresponding box (Full GPU scalling) sothat the image come back.

Here is my xorg.conf... I don't get why the hell nvidia-settings always put Full GPU Scalling ON.


Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Thu Jun  5 09:27:12 UTC 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Thu Feb 14 18:13:41 PST 2008
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard" "CoreKeyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "oss"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "NUL TV-2003"
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 80.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS 512"
    Option         "ExactModTimingsDVI"
    Option         "ModeValidation" "NoDFPNativeResolutionCheck"
#    Option         "FlatPanelProperties" "Scaling = Native" 
    Option         "FlatPanelProperties" "Scaling = DFP"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinViewOrientation" "Clone"
    Option         "SecondMonitorHorizSync" "30-50"
    Option         "SecondMonitorVertRefresh" "50"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1024x768 +0+0, DFP: 720x576_50 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Thank you a lot !!!!
bigadel is offline   Reply With Quote