View Single Post
Old 09-15-08, 03:35 PM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Disabling sound over HDMI ? SOLVED

Quote:
Originally Posted by bram View Post
My TV, Sony XBR-4 has no setting for this.

And there are people who are able to help out, ankh just solved it for me:
http://www.nvnews.net/vbulletin/show...18&postcount=6

Sound-over-HDMI is disabled if you do
"UseEDID" "False"

This, however, has nasty side effects, so the best course of action (until nvidia implements a driver option) is to use "CustomEDID".
In short, you need to remove the extended block from the EDID you get from your TV.

Bram
OK, but wouldn't you think there should be an

Code:
Option    "HDMIAudio" "disable"
flag in your xorg.conf file? Or a checkbox in nvidia-settings? We don't know that though. Glad you found a workaround, but I sure hope there are less strenuous means of stopping audio over HDMI for less techno-savy users.
mooninite is offline   Reply With Quote