View Single Post
Old 08-24-03, 04:03 AM   #1
m707
Registered User
 
Join Date: Aug 2003
Location: Germany
Posts: 2
Angry return from tvout (long -soory)

Hi,

My hardware:

Asus 7100 GF2 MX-tvout
A7V 133
Athlon 1.4
512 MB RAM
IIyama 501 (22" CTR)
Panasonic TV - PAL

My Software:

debian sarge
2.4.21-xfs-preempt
Xfree 4.2
Nvidia-4496

gentoo 1.4rc3
2.4.20-xfs
Xfree 4.3
Nvidia 4363

Both use vesa framebuffer for console (vga=791: 16bit 1024*768)

I boot on console and start X by two wraper scripts copying the X config file to start X on ctr or TV.

The CTR config file:

---cut---
Section Module
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
Load "glx"
Load "v4l"
.....
Section "Monitor"
HorizSync 30-130
Identifier "Monitor[0]"
ModelName "VISION MASTER PRO 510 (A201HT)"
VendorName "IIYAMA"
VertRefresh 50-160
Option "IgnoreEDID" "on"
....
Section "Screen"
DefaultDepth 24
SubSection "Display Depth 24
Modes "1600x1200" "1280x1024" "1152x870" "800x600" "640x480"
"
.....

Section "Device"
BoardName "GeForce 2 MX"
BusID "1:0:0"
Driver "nvidia"
Option "NvAGP" "3"
Identifier "Device[0]"
VendorName "Nvidia"
Videoram 32768
.....
Section "ServerLayout"
Identifier "Layout[all]"
....
Option "Xinerama" "off"
Screen "Screen[0]"
---cut---

Differences of TV config in Section device:

---cut---
Section "Device"
BoardName "GeForce 2 MX"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "Nvidia"
Videoram 32768
Option "IgnoreEDID"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "TV"
Option "TwinViewOrientation" "LeftOff"
Option "MetaModes" "800x600, 800x600"
---cut---

The script wms links the ctr-config to /etc/X11/XF.. and the script wmtv links the tv config.

When I return from a TV session (by closing the WM or killing X) the ctr does not get back the video signal . The TV shows some flickering pics but the ctr remains in standby. Even if I call explicitly the ctr setup by wms nothing hapens. However, the system is not dead I can do both reach it by ssh and return to the TV session by typing wmtv again.

Before I upgrade my debian kernel and switched to nvidia 4496 I used 2.4.18 with 4191 on the box for quite a long time further there are sources of 3123 and 2960 in /usr/local/src, so I supposed I used them, too, without any problem in returning to the console comming from TV out. I use the vesa framebuffer from early 1xxx drivers on, too. Never had such problems.

I re-read the README, looked at the Changelog and searched the archive, but failed to get a useful info on this matter. The X logfile (/var/log/XF..log) does not show any problems, too.

Any hint greatly apprecitated, TIA.

--
bye - maik
m707 is offline   Reply With Quote