View Single Post
Old 10-15-08, 02:53 PM   #9
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by mdweinberg View Post
I tried that earlier. All the modes are then rejected by the internal driver mode of 640x480
or 800x600. There seems to be no way to manually specify the native resolution of the
panel without EDID.
You can force it, but it involves adding a modeline, for my 1920x1200 LCD monitor this modeline (got from http://ubuntuforums.org/archive/index.php/t-401556.html) works:
Modeline "1920x1200_60.00" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +Hsync -Vsync
Unfortunately tools like gtf or http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
were unable to give me a Modeline with a 154Mhz pixel clock at 60Hz that my monitor needs.

Apart from the mode line, to force a resolution without EDID you also need to add stuff like:
Option "ModeValidation" "NoMaxPClkCheck"
Option "ExactModeTimingsDVI" "True"
Modes "1920x1200"
Option "ModeValidation" "string"

Another option you may or may not need to force a resolution is:
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Let me know if you are able to force your resolution with the above options.
Look here for more info:
http://us.download.nvidia.com/XFree8...ModeValidation

By the way, I'm working on editing my EDID file and changing the DPMS values.
It's very promising.
Please use nvidia-settings -> aquire EDID and attach the generated edid.bin files for both your monitors.
I can take the power setting from one edid file and put it on the other.
sordna is offline   Reply With Quote