View Single Post
Old 10-16-08, 10:02 AM   #11
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by sordna View Post
You can force it, but it involves adding a modeline, for my 1920x1200 LCD monitor this modeline (got from http://ubuntuforums.org/archive/index.php/t-401556.html) works:
Modeline "1920x1200_60.00" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +Hsync -Vsync
Unfortunately tools like gtf or http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
were unable to give me a Modeline with a 154Mhz pixel clock at 60Hz that my monitor needs.

Apart from the mode line, to force a resolution without EDID you also need to add stuff like:
Option "ModeValidation" "NoMaxPClkCheck"
Option "ExactModeTimingsDVI" "True"
Modes "1920x1200"
Option "ModeValidation" "string"

Another option you may or may not need to force a resolution is:
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Let me know if you are able to force your resolution with the above options.
Look here for more info:
http://us.download.nvidia.com/XFree8...ModeValidation

By the way, I'm working on editing my EDID file and changing the DPMS values.
It's very promising.
Please use nvidia-settings -> aquire EDID and attach the generated edid.bin files for both your monitors.
I can take the power setting from one edid file and put it on the other.
Thanks!!!! That works for me. Sleep is back.

I did not know about the ExactModeTimingsDVI and that was my problem.

BTW, I got out my hexeditor and made the same changes to my edid.bin and used CustomEDID to
try it. But that did not seem to make a difference.
mdweinberg is offline   Reply With Quote