View Single Post
Old 10-16-08, 11:44 AM   #14
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

My guess is: if the EDID reports HDMI audio, then the driver enables it (and apparently the monitor disables the analog audio input).

I think nvidia-settings should provide an option to enable/disable HDMI audio, so users can choose.

Anyway, please attach the viewsonic's edid.bin and I can modify it to disable the HDMI audio,
update the checksum, and attach it back to you. It will be a good test.
You can then tell xorg to load that one, instead of pull it from the monitor:
Option "CustomEDID" "DFP-1:/etc/X11/edid.bin"
sordna is offline   Reply With Quote