View Single Post
Old 09-16-02, 11:56 PM   #1
z28Power
Registered User
 
Join Date: Sep 2002
Location: Reno, NV, US
Posts: 15
Default My source RPM won't build right! Details Inside.

I downloaded the .src.rpm file for build 3123 of the nvidia drivers for my Ti4200. The rpm --build command worked fine, however when I tried to run the rpm -ivh /usr/src/rpm/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm file, I get the following message:
Code:
error: failed dependencies:
  kernel >= 2.2.0 is needed by NVIDIA_kernel-1.0-3123
  rpm >= 3.0.4 is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123
  /bin/sh        is needed by NVIDIA_kernel-1.0-3123
I have kernel 2.2.19 of linux, and 3.4.x of rpm
I know the sh command works because I used it to upgrade my xwindows just earlier, and have used the NVchooser.sh program as well!

This all occured after the make install command from the .tar.gz failed as well. I feel like I'm almost there but something is just a little bit off!! any help would be greatly appreciated!
(When I try to do it with the .tar.gz files, I get unresolved symbol errors and it does not complete.)

Last edited by z28Power; 09-17-02 at 12:41 AM.
z28Power is offline   Reply With Quote