View Single Post
Old 10-25-08, 09:06 AM   #4
zare
Registered User
 
Join Date: Sep 2008
Posts: 5
Default Re: GeForce3 Ti200 96xx problems on FreeBSD 7.

I am sorry for very late reply, but i dropped the issue for the time being (i haven't got any solutions).

The built-in nv driver works as it should. However, i need at least 2D acceleration.

Here's the sysctl output;

Quote:
hw.nvidia.agp.card.rates: 4x 2x 1x
hw.nvidia.agp.card.fw: not supported
hw.nvidia.agp.card.sba: not supported
hw.nvidia.agp.card.registers: 0x1f000007:0x00000000
hw.nvidia.agp.status.status: disabled
hw.nvidia.agp.status.driver: n/a (unused)
hw.nvidia.agp.status.rate: n/a (disabled)
hw.nvidia.agp.status.fw: n/a (disabled)
hw.nvidia.agp.status.sba: n/a (disabled)
hw.nvidia.version: NVIDIA FreeBSD x86 Kernel Module 96.43.07 Sun Jul 6 22:56:23 PDT 2008
hw.nvidia.registry.EnableVia4x: 0
hw.nvidia.registry.EnableALiAGP: 0
hw.nvidia.registry.NvAGP: 3
hw.nvidia.registry.EnableAGPSBA: 0
hw.nvidia.registry.EnableAGPFW: 0
hw.nvidia.registry.SoftEDIDs: 1
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.FlatPanelMode: 0
hw.nvidia.registry.DevicesConnected: 0
hw.nvidia.registry.RmLogonRC: 1
hw.nvidia.registry.DetectPrimaryVga: 1
hw.nvidia.registry.dwords:
hw.nvidia.cards.0.model: GeForce3 Ti 200
hw.nvidia.cards.0.irq: 16
hw.nvidia.cards.0.vbios: ??.??.??.??.??
hw.nvidia.cards.0.type: AGP
The X11 configuration is generated by nvidia-xconfig, with the option NvAGP line enabled and with agp.ko loading disabled both in loader.conf and in device.hints. Changing sysctl entry for NvAGP shows 1->1, therefore it's already enabled. Three days ago, i installed FreeBSD 7 on my Toshiba Satellite Pro, with nVidia Geforce4Go 420. Same thing! Just on the laptop, the system doesn't hang, it shows some random jibberish on the screen, but i can kill X and return to console.

This is the procedure, for both computers;

- Download latest legacy 96.xx drivers;
- Unpack, make install;
- Run nvidia-xconfig.
- Disable agp.ko in loader.conf
- Disable agp kernel module via device.hints.
- Reboot.
- ****.
zare is offline   Reply With Quote