View Single Post
Old 09-17-02, 09:10 AM   #7
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default failed some dependencies....

Quote:
Originally posted by cyko
I'm new to linux, but have used FreeBSD for quite some time now. I'm currently running Red Hat 7.3 with kernel 2.4.19.

I followed your instructions exactly as you have said, but I continue to get:
error: failed dependencies:
XFree86 >= 4.0.1 is needed by NVIDIA_GLX-1.0-3123
I had X4 working before I tried installing these drivers. What can I do to resolve this?

Thank you for your time.
Well, I think your X are installed( but 4.2.1.. is installed by you, not from RPM,i supose).

check with:

rpm -qa | grep XFree

This give you a list of rpm's installed that contain Xfree


you can "force" nvidia drivers to install

If you had a previous Nvidia drivers installed
rpm -qa | grep NV

I recommend you uninstall them:

rpm -e NVIDIA_GLX NVIDIA_kernel


and install it
rpm -i NV* --nodeps

if this doesn't work
force it
rpm -i NV* --nodeps --force

If you install a package from sources, RPM dabatabase is not actualized, and you can have XFree 4.2.1 and RPM's database say you only have Xfree 4.0

If you installed from RPMS, rebuild your database

rpm --rebuilddb ( I supose is this option, check rpm --help or info rpm )
utiel is offline   Reply With Quote