Thread: mplayer vdpau
View Single Post
Old 11-15-08, 09:52 AM   #45
tx2rx
Registered User
 
Join Date: Jun 2005
Posts: 18
Default Re: mplayer vdpau

Quote:
Originally Posted by bexbier View Post
hy

at first .... nic to hear that came out nice stuff for hardware decoding on linux ...BIG THX FOR THAT !!

but i have an problem to compile mplayer with the checkout-patch script :

Code:
coder.o loader/dmo/buffer.o loader/dmo/dmo.o loader/dmo/dmo_guids.o libmpcodecs/vd_xanim.o stream/ai_oss.o libmpeg2/idct_mmx.o libmpeg2/motion_comp_mmx.o mp3lib/decode_i586.o mp3lib/decode_mmx.o mp3lib/dct64_sse.o mp3lib/dct64_mmx.o libswscale/libswscale.a libavformat/libavformat.a libavcodec/libavcodec.a libavutil/libavutil.a libpostproc/libpostproc.a  -Wl,-z,noexecstack    -lz -lpthread -ldl -rdynamic  -lm   
libavcodec/libavcodec.a(allcodecs.o): In function `avcodec_register_all':
allcodecs.c:(.text+0x25d): undefined reference to `h264_vdpau_decoder'
allcodecs.c:(.text+0x64d): undefined reference to `vc1_vdpau_decoder'
allcodecs.c:(.text+0x701): undefined reference to `wmv3_vdpau_decoder'
collect2: ld returned 1 exit status
make: *** [mplayer] Fehler 1
im running ubuntu 8.10 on an p5n7a-vm

how can i fix it ?

regards

bex
I ran into the same issue use instead:

./configure --enable-vdpau

Make sure you make clean and then run make again.

Regarding the playback, the sample worked fine but like others I've run into problems like:

Quote:
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration
Error at libvo/vo_vdpau.c:826
I guess it's a matter of time for the driver and library/API to stabilise abit
tx2rx is offline   Reply With Quote