Thread: mplayer vdpau
View Single Post
Old 11-15-08, 10:43 AM   #47
r0mik
Registered User
 
Join Date: Nov 2008
Location: Ukraine / Kiev
Posts: 2
Default Re: mplayer vdpau

Hi!
I get this error:

Code:
/usr/local/mplayer-vdpau/bin/mplayer -vo vdpau -vc ffh264vdpau films/Napragi\ izvilini.mkv 
MPlayer dev-SVN-r27408-4.3.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing films/Napragi izvilini.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Get.Smart.2008.720p.BluRay.x264-SiNNERS", -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang rus
[mkv] Track ID 3: audio (A_AC3), -aid 1, -alang eng
[mkv] Track ID 4: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
DVB card number must be between 1 and 4
AO: [null] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration 
Error at libvo/vo_vdpau.c:180
VDP_STATUS = 1
This error in:
Code:
    // Create Device
    vdp_st = vdp_device_create_x11(
        mDisplay, //x_display,
        mScreen, //x_screen,
        &vdp_device,
        &vdp_get_proc_address
    );
    CHECK_ST
vdp_device_create_x11 returns an error VDP_STATUS_NO_IMPLEMENTATION (No backend implementation could be loaded).

Running an GF8400M-GS.

What this?


Thanks!
r0mik is offline   Reply With Quote