Thread: mplayer vdpau
View Single Post
Old 11-15-08, 11:57 AM   #50
SilentLexx
Registered User
 
SilentLexx's Avatar
 
Join Date: Dec 2007
Location: Ukraine / Sumy
Posts: 112
Default Re: mplayer vdpau

Problem with mkv (h.264). MPEG1/2 works fine.

Log:
Code:
mplayer -vo vdpau -vc ffh264vdpau HDScape.StarGaze.HD.Universal.Beauty.2008.mkv
MPlayer dev-SVN-r27408-4.3 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ (Family: 15, Model: 107, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

Playing HDScape.StarGaze.HD.Universal.Beauty.2008.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[h264_vdpau @ 0x88f2690]brainfart cropping not supported, this could look slightly wrong ...
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1920 x 1080 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 HIGH VDPAU acceleration
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
VDPAU capture: Enabled
vdp_imp_device_create_x11()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_get_proc_address()
vdp_presentation_queue_target_create_x11()
vdp_presentation_queue_create()
vdp_decoder_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_surface_create()
vdp_video_mixer_create()
vdp_output_surface_create()
vdp_output_surface_create()
[h264_vdpau @ 0x88f2690]brainfart cropping not supported, this could look slightly wrong ...
vdp_decoder_render()
vdp_decoder_render()
vdp_decoder_render()
Error at libvo/vo_vdpau.c:826
Card:
Code:
cat /proc/driver/nvidia/cards/0
Model:           GeForce 9800 GT
IRQ:             16
Video BIOS:      62.92.49.00.11
Card Type:       PCI-E
DMA Size:        40 bits
DMA Mask:        0xffffffffff
Bus Location:    02.00.0
__________________
PS: I'm sorry, but my english is very bad
openSUSE 11.1, Gigabyte GA-M57SLI-S4, AMD Athlon64 X2 +4800@2500MHz, 2 GB RAM, GeForce 9800GT.
openSUSE 11.0, MSI M670X, AMD Sempron +3600@2000MHz, 2 GB RAM, GeForce 6100 Go.
Ubuntu 8.10, Albatron KM266Pro, AMD AthlonXP +1800@1600MHz, 1 GB RAM, GeForce 4 MX440.
SilentLexx is offline   Reply With Quote