Thread: mplayer vdpau
View Single Post
Old 11-15-08, 12:32 PM   #53
bexbier
Registered User
 
Join Date: Oct 2008
Posts: 19
Default Re: mplayer vdpau

Quote:
Originally Posted by Stephen Warren View Post
You don't have all the required development packages installed (i.e. header files, lib .so symlinks).

I'm not familiar with Ubuntu, but on Fedora you can fix this by doing this:

yum groupinstall "X Software Development"

Presumably, there's something roughly equivalent for Ubuntu.
hy Stephen Warren

i put --enable-vdpau behind "./configure" on the script ( like tx2rx said) and after this i had no more problem



Code:
#!/usr/bin/env sh

set -e
set -x

co_dir=mplayer-vdpau

svn co --ignore-externals -r 27408 svn://svn.mplayerhq.hu/mplayer/trunk ${co_dir}
cd ${co_dir}
svn co -r 14529 svn://svn.mplayerhq.hu/ffmpeg/trunk/libpostproc
svn co -r 14529 svn://svn.mplayerhq.hu/ffmpeg/trunk/libavformat
svn co -r 14529 svn://svn.mplayerhq.hu/ffmpeg/trunk/libavcodec
svn co -r 14529 svn://svn.mplayerhq.hu/ffmpeg/trunk/libavutil

patch -p0 < ../mplayer-vdpau-mplayer.patch 
patch -p0 < ../mplayer-vdpau-libavutil.patch 
patch -p0 < ../mplayer-vdpau-libavcodec.patch 

./configure --enable-vdpau
make
bexbier is offline   Reply With Quote