Thread: mplayer vdpau
View Single Post
Old 11-20-08, 11:03 AM   #118
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

Quote:
Originally Posted by MarkG View Post
Would it be possible to get the correct version of libx264 from git and compile it along with ffmpeg so errors like this don't show up, depending on what version is in the distro being used?
Probably not; I mean, we could fetch the code and build x264 and force Mplayer/ffmpeg to build against it, but then running MPlayer wouldn't work, because we wouldn't be able to force MPlayer to find the correct libx264 .so file at runtime. To solve this, we'd have to either write complex instructions on how to set LD_LIBRARY_PATH correctly, or somehow hack MPlayer to build with LD_RUN_PATH. Neither of these are what we really want to spend time on supporting.

However, we could disable x264 support when configuring MPlayer, via:
Code:
--disable-x264-lavc --disable-x264
I'll make sure this gets added to the build script.
Stephen Warren is offline   Reply With Quote