View Single Post
Old 11-22-08, 06:31 AM   #1
HenryHu
Registered User
 
Join Date: Aug 2008
Posts: 24
Default About the new VDPAU interface

I'm trying to get VDPAU to work.
First, the nvidia driver does not install the header files. So I installed them to /usr/local/include/vdpau
And then, I've got the new source and compiled.
I have to disable ass, or mplayer cannot find colorspace, since ass video filter does not support vdpau's special colorspace formats.
And now, mplayer crash in vdp_imp_device_create_x11. Signal 11.
It says that it crashes in libthr.so.3
We know that nvidia's driver still use FreeBSD 5's libraries, and libvdpau_nvidia.so depends on /usr/local/lib/compat/libpthread.so.1, which implements pthread functions as libthr.so.
I don't know the cause of the problem, but, please release a driver built on FreeBSD 7...
FreeBSD 5 is just too old...
And I always get "libc.so.5, required by libGLcore.so.1, may conflict with libc.so.7"....
HenryHu is offline   Reply With Quote