Thread: mplayer vdpau
View Single Post
Old 11-28-08, 01:41 PM   #185
theuni
Registered User
 
Join Date: Nov 2008
Posts: 27
Default Re: mplayer vdpau

Stephen-

I'll post the output for a HIGH profile h264 movie, they all end the same way.

./mplayer -vc ffh264vdpau -vo vdpau /tmp/test.mkv
Code:
MPlayer dev-SVN-r27960-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 11)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /tmp/test.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x688  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1280 x 688 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.86:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x688 => 1280x688 H.264 HIGH VDPAU acceleration
A:   0.0 V:   0.0 A-V:  0.042 ct:  0.000   0/  0 ??% ??% ??,?% 2 0

Exiting... (End of file)
I see one frame, then it closes.

I'm also seeing the same mixed up frames as everyone else on the movies that do work, but it sounds like that's a known issue.

Thanks again for your work on this project. It's finally putting a reasonable htpc within reach...

TheUni
theuni is offline   Reply With Quote