Thread: mplayer vdpau
View Single Post
Old 11-28-08, 01:50 PM   #186
sensimilla
Registered User
 
Join Date: Nov 2007
Posts: 17
Default Re: mplayer vdpau

Here is the output of mplayer when it fails playing an mkv :

Quote:
phooey:~/mplayer-vdpau-3139462/mplayer-vdpau$ ./mplayer -vo vdpau -vc ffh264vdpau /media/data/720p/IMAX\ Roving\ Mars/rev-roving.mars.x264.mkv
MPlayer dev-SVN-r27960-4.3.2 (C) 2000-2008 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ (Family: 15, Model: 43, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

Playing /media/data/720p/IMAX Roving Mars/rev-roving.mars.x264.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
================================================== ========================
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration
Error 25 at libvo/vo_vdpau.c:849: 0.004 0/ 0 ??% ??% ??,?% 4 0
The window opens very briefly showing a green screen and then mplayer exits.

All the same .mkv files that I have tried play fine when not using vo vdpau -vc ffh264vdpau using the same mplayer binary. (at least as far as my underpowered CPU lets them).

I am using an 8800GT if that helps with the 180.08 driver.
sensimilla is offline   Reply With Quote