View Single Post
Old 09-18-02, 08:11 AM   #11
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default Update

Well with the new driver release I had the same problems. However not satisfied that no one else was getting these problems I dug a bit deeper to find the problem and finally success. I think it was my monitor is being fussy or lieing to the video card about what it can do(anyone want to explain?).

Shortend story follows what I did
1. Login to gnome redhat. Hold down ALT + CTRL and press F1. This takes you to a text login. So login as root. Then run "Xconfigurator". This will make you a XF86Config-4 file for the vesa(default) driver. In my case everything had to be done custom. Example my montior is a hitachi CM615 not listed so select custom and I enter the horizontal and vertical frequencies from the hardware manuel. Next is video card setup which you can either probe(didnt work) or do manually. In my case i have a ti4200 w/64mb. So select 64mb VRAM and for the Clockchip(no idea what I should have choosen) select the setting that says no clockchip(or recommended next to it). Next I think you select what resoulution that you want redhat to be able to work in use space-bar to select the ones you want I choose 1280x1024, 1024x768, and 800x600 in all three color settings 8bit, 16 and 24bit. Do a test and your done and back at the text console. If you reboot here then you shouldnt have the problems like in the jpegs I posted except your using the vesa driver not the optimised nvidia one, so read on before restarting.

2. Hold ALT + CTRL and press F7 (may take a few goes it was senstive on my system). Now go to the folder /etc/X11/ and edit the XF86Config-4 file that was just created as per the nvidia instuctions remove Load "dri", Load "GLcore" and Load "glx" should already be there.

3. Restart the PC. Now if like me you get the results in the jpeg earlier. look at the log file /var/log/XFree86.0.log
at the top of the text it explains what the symbols mean. In my case I had a stack of warnings. All of which where along the lines of this resolution needs adjusting blah blah blah EIDE blah blah. Now because Ive spent some time trying different config files and seeing what other had I added this line to the config file which fixed all my problems.

In the section for your graphics card add at the bottom
Option Option "IgnoreEDID" "true"

Oh and if like me youd prefer 24bit color over 16 then go down to the section with all the resolution and change the default color depth from 16 to 24

Save and restart your PC.

ENJOY

Also could someone take a look and explain to me in detail what each of these line in the config file does. Ill attach my file so you can see what I would like explained. Because when I was playing around with it some lines i could comment out/remove and they didnt make any obvious differences. So do I really need these?

Lastly yes I am a linux newbie so most of this is probly obvious to most of you but us newbies not in the know I beleive this could help some of us. Oh yeah and if you are like me when I first loaded redhat on it didnt detect 1 of my 2 network card and your sound card dosnt work. Go into your BIOS and disable/turn off the setting for Plug and Play(PnP) OS it works a treat

Couple of questions to.
1. Cause ive been mucking around in the root users account is there someway to reset it to the default as when I logged in the first times(redhat defaults).

2. What do I need to add the the config file to get it to default to one of the resoluton say 1024x768 at 85hz?
Attached Files
File Type: txt xf86config-4.txt (2.1 KB, 161 views)
Petz is offline   Reply With Quote