View Single Post
Old 09-03-03, 03:40 PM   #6
Registered User
Join Date: Sep 2003
Location: Clemson, SC
Posts: 5


here was my solution to the problem. Become root for all steps.

First remove any kernal-source rpms you have on the system. Then go to /usr/src and delete the kernel source directory, usually linux-2.4.xx.SuSE. Then go back and install the kernel-source rpm. Now use Yast Online update to update the kernel-source package to the current set.

After that, open a terminal and go to the /usr/src/linux directory. The linux is acutally a link that should be updated by the rpm. If not make it point to the kernel source directory. Ok, in the directory /usr/src/linux run the following:

make cloneconfig

make dep clean

Both should run without errors and may take awhile depending on the machine.

now cd to


view the file version.h

now run 'uname -r' If the versions match then go to console 1 (ctrl+alt+f1) and change to run level 3 (init 3 as root) to kill the xserver. If they don't match then you still need the correct source. You can manually get the source for your kernel from the site.

Extract the nvidia install package with the --extract-only switch.

change into the nvidia directory and then to ./usr/src/nv

edit the Makefile in this directory to include the following line:


This will ignore the gcc version problem. I got the error even though my kernel was compiled by the same version gcc.

now change back to the base nvidia directory (cd ../../..) and run the nvidia_installer executable.

The installer should now compile and insert without problems.

Reboot to run level 3, don't let an xserver start after the reboot.

Do not use sax to set up your display!

Manually edit the XF86config file using the options in the nvidia readme to set up your graphics card. Hopefully you had a running xserver before so you just need to modify the device section. If not, then good luck building an XF86config file. It is not too hard. You can find templates.

Then test your xserver (startx). It should work provided there are no typos.

Good Luck!

cosborn is offline   Reply With Quote