View Single Post
Old 12-07-08, 04:15 AM   #3
Guspaz
Registered User
 
Join Date: Apr 2003
Posts: 5
Default Re: 180.11 powermizer still broken

You can actually force the drivers into high-performance mode. Here is a script to do it:

Code:
#!/bin/bash

echo 'Forcing GPU to high-performance mode. Press CTRL-C to stop.'
let x=0
while true; do
        let y=x*25
        echo -ne "\rTime spent in high performance mode: $y seconds"
        nice /usr/bin/nvidia-settings -q all > /dev/null &
        let x=x+1
        sleep 25;
done
This script goes a bit fancy, here is a simpler version that should do the same thing with less glitter:

Code:
#!/bin/bash

while true; do
        nice /usr/bin/nvidia-settings -q all > /dev/null &
        sleep 25;
done
You could also replace "true" with ":"

For an explanation as to what this does, it queries nvidia-settings for a list of settings every 25 seconds.

This works because when you query nvidia-settings, it forces the GPU into high performance mode (powermizer level 2 for me, since I have 0/1/2) for 30 seconds. So this script, while running, will permanently keep your GPU in max performance mode as long as it runs.

With this, you can indeed toggle powermizer on and off.

I can't take complete credit for it, though, I found the original solution in the Ubuntu forums, and wrote the fancified script based on that.

Now my biggest complaint is simply that vsync doesn't work with Compiz in any nVidia drivers, most annoyingly in video

EDIT: My bad, it looks like 180.11 (installed the Jaunty package into Intrepid) significantly improves (if not fixes) my vsync issues with Compiz. With that and the visual corruption bugs that 180 is listed as fixing (and did fix), the only remaining issues that I have with Compiz are now resolved. Woot!
Guspaz is offline   Reply With Quote